138 résultats trouvés

par steph31
06 févr. 2019, 10:52
Forum : Electronique
Sujet : Téléinfo sur arduino
Réponses : 18
Vues : 652

Re: Téléinfo sur arduino

Pour être plus précis: Je possède 2 Magelis XBTGT2130 donc un qui me sert sur mon installation et le deuxième que je garde pour faire des tests. J’ai 3 projets vigeo que j’ai créé. 1 :« Comteur_REV2 » est celui qui est chargé actuellement dans mon écran qui fonctionne. J’ai chargé ce projet sans pro...
par steph31
04 févr. 2019, 13:47
Forum : Electronique
Sujet : Téléinfo sur arduino
Réponses : 18
Vues : 652

Re: Téléinfo sur arduino

J'ai essayer avec l'ancien projet (celui qui est dan l’écran actuellement), j'ai le même message , alors que celui ci j'ai peu le transféré auparavant. J'ai redémarré l’écran et le PC ça ne change rien.
par steph31
04 févr. 2019, 12:38
Forum : Electronique
Sujet : Téléinfo sur arduino
Réponses : 18
Vues : 652

Re: Téléinfo sur arduino

Bonjour J’ai rajouté la partie téléinfo dans mon projet vigéo. Je n’ai pas d’erreurs à la compilation, mais quand je transfert le projet dans la cible, j’ai ce message ? Si je fais continuer en cliquant sur « OUI » ça fini par une erreur de communication et l’écran redémarre sur le runtime actuel. Q...
par steph31
01 févr. 2019, 09:47
Forum : Electronique
Sujet : Téléinfo sur arduino
Réponses : 18
Vues : 652

Re: Téléinfo sur arduino

C’est ce que j’avais prévu au départ : ma carte devait fonctionnée en modbus esclave pour pouvoir être appelé par le XBTGT2130. L’IHM est configuré en modus master sur le COM2 sur lequel j’ai 2 esclaves modbus. Capture2.PNG Mon souci, c’est que je n’ai pas pu faire fonctionné simultanément la librai...
par steph31
31 janv. 2019, 10:11
Forum : Electronique
Sujet : Téléinfo sur arduino
Réponses : 18
Vues : 652

Re: Téléinfo sur arduino

slts, on présume que c'est écris dans une action périodique à 1s , à préciser. Bonjour C’est exactement ça : J’ai essayé avec plusieurs valeurs périodiques 0.1S a 2,5S Sachant que ma carte envoie la trame toute les 2 secondes approximativement, j’ai mis une valeur de 2S pour la valeur périodique. C...
par steph31
30 janv. 2019, 09:28
Forum : Electronique
Sujet : Téléinfo sur arduino
Réponses : 18
Vues : 652

Re: Téléinfo sur arduino

Je n’arrive pas à faire fonctionné le modbus avec la téléinfo. Je voulais envoyer ses trames modbus vers un Magelis XBTGT2130 qui me sert de passerelle modbus RTU S7 TCP IP. J’ai simplifié mon programme dans l’Arduino en supprimant des options et en conservant le plus important pour moi :la consomma...
par steph31
27 janv. 2019, 17:27
Forum : Electronique
Sujet : Téléinfo sur arduino
Réponses : 18
Vues : 652

Re: Téléinfo sur arduino

J’utilise la librairie softwareserial pour la réception de la trame téléinfo. Le modbus utilise l’UART principal de l’atmega 328. Le code source exemple récupère la téléinfo pour la retransmettre sur un PC avec la fonction Serial.Print via l’UART de l’arduino. J’ai viré les fonctions qui concerne la...
par steph31
27 janv. 2019, 12:36
Forum : Electronique
Sujet : Téléinfo sur arduino
Réponses : 18
Vues : 652

Téléinfo sur arduino

Bonjour Je travaille sur une passerelle télé info EDF Modbus RTU avec un Arduino. Ça fait un moment que je cogite sur le code pour faire fonctionné celui-ci. Mon souci, je ne parviens pas à faire fonctionné les 2 UART simultanément. Quand la liaison téléinfo est connecté à mon arduino et la fonction...
par steph31
09 nov. 2018, 18:19
Forum : Supervision industrielle
Sujet : Communication impossible PC API Wincc flexible
Réponses : 10
Vues : 477

Re: Communication impossible PC API Wincc flexible

OK merci JC87 je me renseignerait au prés de mon fournisseur Siemens pour la SP5. En revanche wincc flexible fonctionne très bien sur mon PC portable sous Windows 10 64bits.
par steph31
08 nov. 2018, 22:38
Forum : Siemens
Sujet : IM151-1 L'esclave DP n'est pas prêt pour l'échange de données [RÉSOLU]
Réponses : 15
Vues : 764

Re: IM151-1 L'esclave DP n'est pas prêt pour l'échange de données

sinced a écrit :
03 nov. 2018, 21:45
En fait je suis sur un banc de test. La CPU avait un autre programme dans la carte memoire je l'ai passee en STOP et j'ai recharge toute la conf materielle et le programme. Ensuite quand je passe en RUN et en ligne, j'ai ce message.
Bonsoir
Avez vous fait un effacement général sur votre CPU ?

@+