[CROUZET EM4] BUG affichage display

Partie du forum pour tout ce qui concerne les automates industriels B&R, Beckhoff, Phoenix Contact etc...
Répondre
37C
Apprend le binaire
Apprend le binaire
Messages : 1
Enregistré le : 27 oct. 2019, 19:23

[CROUZET EM4] BUG affichage display

Message par 37C » 27 oct. 2019, 19:38

Bonjour
Je bosse sur des automates crouzet depuis plus de 10 ans, d’abord le M3 et depuis 1 an sur le M4 (super produits)

Sur un programme basique de compteur d'eau, avec un affichage de la conso par impulsion pour le cumul, à la semaine, au mois et à l'année, il s'avère que j'ai un bug au niveau des display, quand certains ce mettent en marche, les autres ne s'affiche plus.
Je suis sur de mon programme
J'ai un double compteur, le premier s’arrête à 999 litres, puis repars à zéro alors que le second compte les M3
Dès lors que mes valeurs dépassent les 1000 litres, j'ai certains display qui disparaissent !

Bon c'est dur à expliquer, mais je laisse un lien vers le prog.....

Je ne sais pas si c'est un bug du logiciel, ou bien un bug du simulateur...enfin bref, je patoge

merci pour votre aide

liens

philou77
Dieu du process
Dieu du process
Messages : 966
Enregistré le : 21 oct. 2015, 10:00

Re: [CROUZET EM4] BUG affichage display

Message par philou77 » 05 nov. 2019, 14:44

Salut !

Post une copie écran de ton prog dont tu es sûr mais qui a un bug ;)
Si vous avez compris tout ce que je viens d'écrire, c'est que j'ai dû faire une erreur quelque part ! :D

Avatar de l’utilisateur
Autoreverse
Asservi son premier moteur
Asservi son premier moteur
Messages : 30
Enregistré le : 04 mai 2019, 12:30
Localisation : 26
Contact :

Re: [CROUZET EM4] BUG affichage display

Message par Autoreverse » 13 nov. 2019, 21:23

Salut,
ça m'est arrivé à plusieurs reprises sur du Millenium3, j'en suis devenu fou au point de créer un programme bidon avec un tas de blocs display.
En faite c'est tout bête, quand on active plus de 8 blocs display en même temps ça fait une caguade !
L'activation du neuvième éteins le premier et ainsi de suite (quand un bloc ne chevauche pas l'autre).
Il à fallu trifouiller un moment avant d'en faire quelque chose de cohérent https://www.youtube.com/watch?v=6DcalZ4 ... e=youtu.be
Il y a de fortes chance que ce soit le même cas sur ton EM4.

Répondre