Variables en #COM sur Citect

Partie du forum pour tout ce qui concerne la supervision industrielle. Forum, conseil, astuce et entraide sur les logiciels de supervision tels que PC Vue, Vijeo designer, WinCC, win cc, monitor pro, so machine, Citect, Intouch .
Répondre
Avatar du membre
sinced
Dieu du process
Dieu du process
Messages : 800
Enregistré le : 13 oct. 2015, 16:56

Variables en #COM sur Citect

Message par sinced »

Bonjour a tous,
J'ai un phenomene bizarre qui se produit.
Je communique avec 1 automate M580 et j'ai une consigne que je souhaiterais envoyer (une consigne en INTEGER).
Malheureusement mon automate arrive a bien lire des variables mais pour ma consigne, j'obtiens un #COM qui s'affiche pourtant je n'ai pas de probleme de communication.
J'ai aussi essaye de me logguer en Admin rien ne change. Avez-vous deja experimente ?
Avatar du membre
JC87
Mi homme - Mi automate
Mi homme - Mi automate
Messages : 1219
Enregistré le : 20 oct. 2015, 13:00
Localisation : Nouvelle Aquitaine

Re: Variables en #COM sur Citect

Message par JC87 »

Bonjour,

C'est quelle version de Citect ? récemment un gars a eu un probléme de ce genre avec un Citect 2018
http://forum-automatisme.net/viewtopic.php?f=22&t=4664
Sinon le #COM peut signifier que Citect n'arrive pas a taper l'adresse que tu a lui donné. Tu travaille avec l'OFS ou en Modnet ?

JC
"On veut faire du zéro défaut mais on a zéro bonhomme et zéro budget, et bien à la fin on a zéro résultat..."
Avatar du membre
sinced
Dieu du process
Dieu du process
Messages : 800
Enregistré le : 13 oct. 2015, 16:56

Re: Variables en #COM sur Citect

Message par sinced »

JC87 a écrit : 04 nov. 2020, 13:10 Bonjour,

C'est quelle version de Citect ? récemment un gars a eu un probléme de ce genre avec un Citect 2018
http://forum-automatisme.net/viewtopic.php?f=22&t=4664
Sinon le #COM peut signifier que Citect n'arrive pas a taper l'adresse que tu a lui donné. Tu travaille avec l'OFS ou en Modnet ?

JC
Je suis en ModNet Citect Scada 2018
Avatar du membre
JC87
Mi homme - Mi automate
Mi homme - Mi automate
Messages : 1219
Enregistré le : 20 oct. 2015, 13:00
Localisation : Nouvelle Aquitaine

Re: Variables en #COM sur Citect

Message par JC87 »

Tu est donc dans le cas de notre ami qui avait un probléme similaire. Il semblerait que ça vienne du fait qu'il faille configure au préalable un accès à un utilisateur. Je trouve ça curieux car ça ne marchait pas comme ça auparavant. Ou alors c'est un tout autre probléme mais je ne vois pas.

JC
"On veut faire du zéro défaut mais on a zéro bonhomme et zéro budget, et bien à la fin on a zéro résultat..."
Avatar du membre
sinced
Dieu du process
Dieu du process
Messages : 800
Enregistré le : 13 oct. 2015, 16:56

Re: Variables en #COM sur Citect

Message par sinced »

J'ai essaye de me logguer j'ai toujours au moins un compte Admin dans mes projets.
Je n'avais pas active de controle d'acces sur cette variable.
Ce qui me semble bizzare c'est qu'apres une sauvegarde/restaurantion, tout refonctionne sans probleme.
job1980
Première mise en service
Première mise en service
Messages : 54
Enregistré le : 28 mai 2019, 14:10

Re: Variables en #COM sur Citect

Message par job1980 »

Salut, je confirme ce que notre ami vous a dit, il faut créer des utilisateurs et se logguer pour pouvoir écrire dans une variable.
En outre, il fait bien faire attention de bien arrêter le serveur pour bien le redémarrer ensuite. J'avais ponctuellement des problèmes de communication qui se résolvaient comme ça, en redémarrant tout proprement. Si ça persiste, je n'ai pas la solution, ça ne m'est pas arrivé
Répondre