API qui ne trouve pas son adresse en DHCP

Partie du forum pour tout ce qui concerne la partie réseau de communication dans l'industrie. Forum, conseil, astuce et entraide sur le réseau industriel tel que la connexion modbus, ethernet, fipio .
Kallysto
Maître du binaire
Maître du binaire
Messages : 417
Enregistré le : 27 avr. 2017, 11:11
Localisation : Loin de la civilisation

Re: API qui ne trouve pas son adresse en DHCP

Message par Kallysto » 23 août 2017, 14:13

sinced a écrit :
21 août 2017, 22:48
Juste pour mon info, en dehors des API, il y a quoi sur ce réseau ?
Parce qu'en général j'ai toujours vu le réseau d'informatique industrielle différent du réseau Entreprise.
Tout et n'importe quoi !

ça va du smartphone au microscope électronique à 2 M€ en passant par le PC de bureau, le PC portable visiteur et le serveur de données.

En fait tout ce qui n'est pas sur le réseau "technique". Où là il n'y a que les machines techniques et une partie de nos automates.
Comme dit plus haut, le problème qu'on rencontre c'est que ce réseau technique n'est pas présent dans tous les bâtiments et que chaque service est géré avec un budget et fait payer ses interventions aux autres... Donc quand le service qui nous gère demande un accès réseau technique, le service IT lui présente une facture... Du coup on ne met sur le réseau technique que l'ultra ultra sensible. (et encore... les chaufferies n'y sont pas (manque le smiley qui se tape la tête contre le mur)).

Pour donner une idée de la taille du bordel, les bâtiments sont codifiés sur 4 chiffres, et le site fait bosser entre 8000 et 10 000 personnes chaque jour si tu comptes tous les intervenants.


Enfin, malheureusement dans le bâtiment, le patchwork est de moins en moins une exception. De plus en plus, sous prétexe que le réseau est "fibré" on se retrouve avec "tout le monde" sur le même réseau... Donc on se retrouve avec un seul et même "câble" dans lequel passe les mails, nos infos API, la vidéo surveillance et l'intrusion. Heureusement, il est encore illégal que l'incendie n'est pas un réseau dédié.
Cela cause les problèmes qu'on connait : perte de vitesse, erreur et plantage quand les mecs se gourent sur des requêtes réseaux, "piratage".

J'ai eu "l'immense bonheur, joie et gloire" de participer à la prog et aux tests du bâtiment qui fait jurisprudence dans la profession et c'était un des gros problèmes : un badgeage pour ouvrir une porte mettait jusqu'à 5 minutes pour remonter au serveur et je mettais pas loin de 2 minutes pour afficher une température :o . impossible de faire mieux ou plus stable. Le problème ne venait pas du matériel mais du fait que le réseau, ultra sécurisé du coup, était saturé. Au final, ils ont mis 5 clampins, un devant chaque porte, pour vérifier les cartes des 1500 personnes qui bossent là dedans (alors qu'une partie du bâtiment aurait du être publique avec accès par badge aux zones privées).
Bon, c'est pas pour ça qu'il a fait jurisprudence le bâtiment, c'est parce qu'il était sensé être BBC et que l'architecte a pondu une verrière de 7 étages de haut dans une zone où il fait 35°C tout l'été... Le 7ème étage n'est pas utilisable à l'année et le 6ème inutilisable en été.

Avatar de l’utilisateur
sinced
Expert de l'héxadécimal
Expert de l'héxadécimal
Messages : 389
Enregistré le : 13 oct. 2015, 16:56

Re: API qui ne trouve pas son adresse en DHCP

Message par sinced » 23 août 2017, 21:54

Donc en fait du point de vue de la cybersécurité, ce type d'installation présente de nombreuses failles pour les automates. Et ces automates ils gèrent quoi ? Des chaudières ou de la GTB/GTC ?

Avatar de l’utilisateur
Mantysse
Créateur de langage
Créateur de langage
Messages : 573
Enregistré le : 20 oct. 2015, 08:17
Localisation : MiP

Re: API qui ne trouve pas son adresse en DHCP

Message par Mantysse » 24 août 2017, 09:03

Oh oui d'un point de vue Cybersécurité c'est un peu la loose le site que nous décrit Kalysto.

Et franchement faudrait pas qu'un ou plusieurs automaticien pètent un plomb... Vue l'état du déploiement de la cybersécurité dans le monde, ça pourrai faire pas mal de dégât... enfin je dis ça je dis rien.
"Ce que l'on conçoit bien s'énonce clairement, et les mots pour le dire arrivent aisément." Nicolas Boileau

L'urgence, c'est fait!
L'impossible, c'est en cours!
Pour les miracles, il faut prévoir un délai!

Avatar de l’utilisateur
JC87
Dieu du process
Dieu du process
Messages : 829
Enregistré le : 20 oct. 2015, 13:00
Localisation : Nouvelle Aquitaine

Re: API qui ne trouve pas son adresse en DHCP

Message par JC87 » 24 août 2017, 09:55

Moi ce qui m'interpelle pour ne pas dire plus dans cette histoire c'est qu'il y a encore en France une boutique avec 10 000 personnes sur un seul site, ça me parait totalement hallucinant dans le contexte de réduction drastique des effectifs qu'on connait en France depuis 30 ans :shock:

JC
"On veut faire du zéro défaut mais on a zéro bonhomme et zéro budget, et bien à la fin on a zéro résultat..."

Avatar de l’utilisateur
Mantysse
Créateur de langage
Créateur de langage
Messages : 573
Enregistré le : 20 oct. 2015, 08:17
Localisation : MiP

Re: API qui ne trouve pas son adresse en DHCP

Message par Mantysse » 24 août 2017, 10:18

JC87 a écrit :
24 août 2017, 09:55
Moi ce qui m'interpelle pour ne pas dire plus dans cette histoire c'est qu'il y a encore en France une boutique avec 10 000 personnes sur un seul site, ça me parait totalement hallucinant dans le contexte de réduction drastique des effectifs qu'on connait en France depuis 30 ans :shock:

JC
Airbus Toulouse c'est au moins ça + un nombre équivalent de sous-traitant divers
"Ce que l'on conçoit bien s'énonce clairement, et les mots pour le dire arrivent aisément." Nicolas Boileau

L'urgence, c'est fait!
L'impossible, c'est en cours!
Pour les miracles, il faut prévoir un délai!

Avatar de l’utilisateur
JC87
Dieu du process
Dieu du process
Messages : 829
Enregistré le : 20 oct. 2015, 13:00
Localisation : Nouvelle Aquitaine

Re: API qui ne trouve pas son adresse en DHCP

Message par JC87 » 24 août 2017, 10:30

C'est vrai que je ne pensais pas à Airbus, mais si tu les enlève avec probablement Eurocopter et bien évidemment PSA/Renault, des usines de 10 000 bédouins il doit pas y en avoir des masses en France. Même Michelin à Clermont ça doit être moins que ça aujourd’hui et en plus ce n'est pas sur un seul site.

JC
"On veut faire du zéro défaut mais on a zéro bonhomme et zéro budget, et bien à la fin on a zéro résultat..."

Kallysto
Maître du binaire
Maître du binaire
Messages : 417
Enregistré le : 27 avr. 2017, 11:11
Localisation : Loin de la civilisation

Re: API qui ne trouve pas son adresse en DHCP

Message par Kallysto » 25 août 2017, 12:12

sinced a écrit :
23 août 2017, 21:54
Donc en fait du point de vue de la cybersécurité, ce type d'installation présente de nombreuses failles pour les automates. Et ces automates ils gèrent quoi ? Des chaudières ou de la GTB/GTC ?
Tout.

Je vais de la chaudière avec auto contrôle obligatoire toutes les 72h au "bête" réseau de radiateurs en fonction de la température extérieure (ça c'est pour le "chaud")
En ventilation, j'ai des centrales pour le confort et d'autres pour le confort "starpoint" (comprendre qu'elle souffle dans la salle de restau du dirlo) ainsi que des labos avec condition de survie à respecter sous peine de péter le zolie microscope élec qu'on devrait donner 47 ans de salaire pour le rembourser (on a compté avec un collègue).
En froid, c'est pareil, j'ai du confort comme du confort starpoint comme la climatisation des salles serveurs qui enregistrent les résultats des expériences et que ça coûte des millions si ils ne font plus leur taff.

Et le mieux, c'est que j'ai des systèmes qui font les deux... par exemple j'ai un groupe froid de secours dans un bâtiment au cas où celui de la salle serveur plante. On avait prévu en cas de panne de couper les réseaux de distributions du groupe froid de secours pour que 100% de sa puissance aille sur le réseau serveur... Bonne idée sauf que ! Ce groupe froid secours ne fait pas que du confort comme il était sensé le faire, il fait aussi des labos qui n'ont pas leur réseau de distribution de froid dédié et sont piqués au milieu des clims des secrétaires...
Donc je peux rien couper, donc on croise les doigts pour que ça tombe en panne en hiver... (c'est cool les fenêtres ouvrantes !)

Y a aussi de la lumière mais ça c'est pas mon problème ni mon bordel et ça me va très bien (surtout que je sais qui les programme et connais son absence total de sérieux et de rigueur)

Ha mais on est d'accord que du point de vue sécu info, c'est loin d'être le top mais bon... C'est pas ma faute.

Le réseau est hyper sécurisé et il y est fait des scan réguliers par le service sécurité info... C'était d'ailleurs ces attaques au hasard qui me foutaient en l'air mes API... et le pire, c'est que la sécu info savait qu'elle m'avait foutu en carafe mes API mais... ne nous le signalait pas.. et moi je cherchais ce qui s'était passé... et pourquoi un coup ça plantait au 4, un coup au 112 et pas au 376...


C'est un site de recherche... Et en fait, on est pas 10 000 mais 14 000 quand y a "tout le monde" (chiffre officiel hier en formation).

Répondre