Surtension Réseau RS485 Mobus RTU

Partie du forum pour tout ce qui concerne la partie réseau de communication dans l'industrie. Forum, conseil, astuce et entraide sur le réseau industriel tel que la connexion modbus, ethernet, fipio .
Répondre
B2du76
Apprend le binaire
Apprend le binaire
Messages : 2
Enregistré le : 04 oct. 2017, 14:34

Surtension Réseau RS485 Mobus RTU

Message par B2du76 » 04 oct. 2017, 15:00

Bonjour,

Je viens vous demander de l'aide sur un problème de surtension dans un réseau RS485.

J'ai un automate Schneider TM172 Maitre avec plusieurs variateurs en esclave qui fonctionne depuis quelque mois, mais nous avons depuis peux,plusieurs automates et plusieurs variateurs qui ont eu leur port RS485 détruit par surtension.

Je suis à la recherche d'info si ce problème a déjà été vue par quelqu'un.

Pour plus de détails, je joins le rapport de Schneider Electric si quelqu'un arrive me traduire ou a expliqué ce qu'ils veulent dire, je suis preneur.
Rapport:
L'analyse interne a porté sur la fonctionnalité de l'unité, les vérifications suivantes ayant été effectuées:
*Le comportement de l'unité après connexion de l'alimentation;
*La communication entre l'unité TM172 et So Machine après branchement d'un câble USB;
*Inspection visuelle en cas d'erreur;
*Si aucun problème n'a été détecté lors des vérifications précédentes, test de l'automate dans le système FTS (Functional Test System).

Les résultats des tests sont les suivants:
*Après connexion de l'alimentation, l'unité a affiché les informations BIOS à l'écran, mais fonctionnait en boucle (redémarrage permanent).
*Après branchement du câble USB, l'unité n'a pas été reconnue par le logiciel (c.-à-d. que le problème signalé par le client a pu être reproduit); lorsque le câble d'alimentation a été débranché, l'unité est toutefois sortie de son fonctionnement en boucle. L'applicatif du client a été détecté.
L'unité a été mise à jour avec l'applicatif du client avant de cesser de fonctionner.
*Le capot en plastique supérieur a été retiré et l'inspection visuelle a permis de constater qu'un composant (DZ4), faisant partie du circuit RS485-2, était endommagé. Un second composant endommagé a été détecté; il s'agissait du pilote de communication IC4. Les bornes +5V et GND de ce composant étaient en court
-circuit, d'où le fonctionnement en boucle de l'unité.

Le problème est très probablement dû à une connexion à chaud lors de la mise sous tension de l'unité. Si, dans l'application, de nombreuses unités sont connectées à la même alimentation (pas de transformateur dédié) et raccordées à la même ligne 485, si le câble d'alimentation est débranché puis rebranché (fil positif en premier), une boucle de courant est générée et se décharge au niveau du point le plus faible du réseau (en principe la connexion série
Merci

Avatar de l’utilisateur
Mantysse
Créateur de langage
Créateur de langage
Messages : 513
Enregistré le : 20 oct. 2015, 08:17
Localisation : MiP

Re: Surtension Réseau RS485 Mobus RTU

Message par Mantysse » 04 oct. 2017, 15:13

Bonjour,

Plusieurs pistes:
1) Gaffe a la CEM
- réseau de com et cable de puissance ne font pas bon ménage dans le même chemin de cable
- Non utilisation de cable blindé pour la com et la puissance
- Utilisation de résistance de fin de ligne sur le réseau RS485
- Mettre le blindage de votre réseau a la masse

2) un périphérique défectueux...
- Moins simple, il te faudrait mettre un enregistreur de tension sur ton réseau... et encore comment savoir ou se situe la génération du pic de tension?? la je sèche.

3) Connectique défectueuse
- Privilégier les connectiques or ou argent pour le réseau

4) je comprend pas très bien la phrase
B2du76 a écrit :
04 oct. 2017, 15:00
Le problème est très probablement dû à une connexion à chaud lors de la mise sous tension de l'unité. Si, dans l'application, de nombreuses unités sont connectées à la même alimentation (pas de transformateur dédié) et raccordées à la même ligne 485, si le câble d'alimentation est débranché puis rebranché (fil positif en premier), une boucle de courant est générée et se décharge au niveau du point le plus faible du réseau (en principe la connexion série
Le matériel est fait pour démarrer a chaud si ce n'est pas le cas change de fournisseur...
Si vous vous connectez physiquement après le démarrage, que connectez vous? Consoles? périphérique?


Bon courage
"Ce que l'on concoit bien s'énnonce clairement, et les mots pour le dire arrivent aisément." Nicolas Boileau

L'urgence, c'est fait!
L'impossible, c'est en cours!
Pour les miracles, il faut prévoir un délai!

B2du76
Apprend le binaire
Apprend le binaire
Messages : 2
Enregistré le : 04 oct. 2017, 14:34

Re: Surtension Réseau RS485 Mobus RTU

Message par B2du76 » 04 oct. 2017, 16:10

Merci pour les pistes.
Pour les câbles, "oui" c'est dans le même chemin de câble, nous somme à l’intérieur d'une tour de refroidissement, les passages ne sont pas séparer. Pour les variateurs, ils sont intégré dans le moteur, donc on utilise du U1000 pour l'alimentation des variateurs et du LIYCY donc blindé pour la com.
Pour les résistances de fin de ligne, on n'en n'utilise pas car on n'a pas de grande longueur et je ne pense pas que cela évite la surtension, je vais en installé, c'est pas le prix que ça vaut mais si cela évite des variateurs et des automate de grillé.
Pour la mise à la masse du blindage, on utilise des étriers de blindage Legrand.
J'ai aussi l'ancienne génération de Schneider le M168 environ 60 tour de refroidissement dans la même configuration avec les même variateurs et aucun problème sur le Modbus.

Je pense vraiment a un problème de CEM chez mes deux client et un nouvel automate un peu moins solide.

Pour le phrase de Schneider, j'ai demandé que l'on m'explique par téléphone mais j'ai toujours pas de réponse.
Il n'y a rien de brancher après mise sous tension, sauf les variateurs s'il y a un arrêt d'urgence seul les variateurs sont remis sous tension, mais ils sont déjà connecté sur le réseau.

Avatar de l’utilisateur
itasoft
Mi homme - Mi automate
Mi homme - Mi automate
Messages : 2426
Enregistré le : 20 oct. 2015, 10:15
Localisation : Lyon
Contact :

Re: Surtension Réseau RS485 Mobus RTU

Message par itasoft » 04 oct. 2017, 21:03

Slts,
Credo à apprendre par cœur :
Toute ligne RS485 différentielle qui ne serait pas polarisée et sans résistances en bouts de ligne est dite
« en l’air » et sensible à des perturbations de toutes sortes.

cliquer dessus
RS485.JPG
Automaticien privé (de tout)
itasoft@free.fr

Répondre