REDLION

Partie du forum pour tout ce qui concerne la partie réseau de communication dans l'industrie. Forum, conseil, astuce et entraide sur le réseau industriel tel que la connexion modbus, ethernet, fipio .
Avatar de l’utilisateur
fish
Expert de l'héxadécimal
Expert de l'héxadécimal
Messages : 344
Enregistré le : 20 oct. 2015, 17:44

Re: REDLION

Message par fish » 02 avr. 2018, 20:41

Salut,
Au pire effectivement une TSXETG100 ferait le boulot.
Et RedLion su mes souvenirs sont bons tout est en english, super !
Qui a fourni cette passerelle ? Et ben, qu'il assure sa mise en service !

MikeKol
Générateur de blocs fonctions
Générateur de blocs fonctions
Messages : 137
Enregistré le : 22 oct. 2015, 20:20

Re: REDLION

Message par MikeKol » 03 avr. 2018, 16:55

fish a écrit :
02 avr. 2018, 20:41
Salut,
Au pire effectivement une TSXETG100 ferait le boulot.
Et RedLion su mes souvenirs sont bons tout est en english, super !
Qui a fourni cette passerelle ? Et ben, qu'il assure sa mise en service !
Je suis entièrement d'accord sur ta deuxième information. Après j'ai une ETG100 mais rien de câbler. On remarque le boulot du chargé d'affaire.

Je pense que le câblage est bon suivant le schéma trouver dans la documentation REDLION

Image

J'ai mit le Marron/Orange et Blanc-Orange / Blanc-Marron. Mais toujours se Rx qui clignote, mais pas le Tx donc l'API me renvoie rien.
A-t-il un outil qui me permet via mon PC de faire une requête MODBUS RTU vers cette API?

Avatar de l’utilisateur
jpratpsft
Générateur de blocs fonctions
Générateur de blocs fonctions
Messages : 102
Enregistré le : 24 nov. 2015, 11:10
Localisation : Blagnac
Contact :

Re: REDLION

Message par jpratpsft » 03 avr. 2018, 17:02

Salut MikeKol,

Moi, je dirai c'est 1 et 8, c'est ce qu'il faut utiliser en RS485 en général (p. 5 du manuel).
De plus, sur le manuel p.6, il y a un schéma qui montre 1/7 pour TxA et 2/8 pour TxB pour du RS485 2 fils.
http://www.redlion.net/sites/default/fi ... nual_0.pdf.

Ta passerelle n'est peut-être pas exactement celle-ci, mais ça doit marcher...

@+
--
Commissaire Bialès : Parlez-moi de vous plutôt…
Odile Deray : Odile. Moi, c'est Odile. Pluto, c'est l'ami de Mickey.
Commissaire Bialès : Ah non, Pluto c'est le chien de Mickey. L'ami de Mickey c'est Dingo.
La cité de la peur

MikeKol
Générateur de blocs fonctions
Générateur de blocs fonctions
Messages : 137
Enregistré le : 22 oct. 2015, 20:20

Re: REDLION

Message par MikeKol » 03 avr. 2018, 17:55

jpratpsft a écrit :
03 avr. 2018, 17:02
Salut MikeKol,

Moi, je dirai c'est 1 et 8, c'est ce qu'il faut utiliser en RS485 en général (p. 5 du manuel).
De plus, sur le manuel p.6, il y a un schéma qui montre 1/7 pour TxA et 2/8 pour TxB pour du RS485 2 fils.
http://www.redlion.net/sites/default/fi ... nual_0.pdf.

Ta passerelle n'est peut-être pas exactement celle-ci, mais ça doit marcher...

@+
Je viens d'essayer pareil le Rx clignote mais le passerelle ne reçois rien.

philou77
Créateur de langage
Créateur de langage
Messages : 524
Enregistré le : 21 oct. 2015, 10:00

Re: REDLION

Message par philou77 » 03 avr. 2018, 18:43

Salut !

Je comprend pas bien ton installation.

je suppose que ta connection entre passerelle et Automate est elle en Ethernet (tu dis qu'elle fonctionne bien)

donc ta connection RS485 est entre ta passerelle et ton appareil, elle devrait être en maitre côté passerelle (si elle est en esclave, je vois pas bien comment l'automate irait rechercher ou écrire des valeur dans ton appareil) ?

Tu dis dans ton post initial que l'esclave est 11 (c'est ton appareil).

Pour que ça marche, il faut UN maitre et DES esclaves !
La passerelle DOIT donc être maitre en MODBUS.
L'automate interroge la passerelle, et la passerelle les esclaves en changeant de réseau... puis la réponse de l'esclave à la passerelle qui redirige vers l'automate..

Mais peut être que je me trompe..
Si vous faites rien aujourd'hui et que votre chef vous dit que vous faisiez déjà ça hier, répondez qu'hier vous aviez pas fini !

MikeKol
Générateur de blocs fonctions
Générateur de blocs fonctions
Messages : 137
Enregistré le : 22 oct. 2015, 20:20

Re: REDLION

Message par MikeKol » 03 avr. 2018, 21:15

Mon automate est maitre, l'automate (GE) lui est esclave @11

PREMIUM => REDLION => GE

Configuration
Image
Image

On peut voir que j'affecte la valeur lu dans l'API GE vers %MW7000 dans mon API PREMIUM
Image

Voila je sais pas si cela répond à ta question.

philou77
Créateur de langage
Créateur de langage
Messages : 524
Enregistré le : 21 oct. 2015, 10:00

Re: REDLION

Message par philou77 » 03 avr. 2018, 22:04

Je ne connais pas du tout ce matériel, mais apparemment
- on voit donc que dans ta passerelle, le port est en Maitre Modbus et ton GE est en esclave.
- je vois pas le passage de la variable depuis GE vers API-ANA mais je suppose qu'il existe une table de l'un vers l'autre...

Donc, en premier lieu, regarde que ton GE, dans sa propre config, soit MODBUS RTU esclave avec l'adresse 11
- Sinon la passerelle ne va pas interroger ton GE...ou ton GE ne va pas répondre à la passerelle

Sinon, il y a peut être une autre possibilité
- Que la passerelle soit en esclave et que ce soit le GE qui lise et écrive dedans !
Dans ce cas, la passerelle doit être en esclave !
Mais je n'y croit pas trop....


ai trouvé cela (en anglais) mais ça donne une idée : http://www.redlion.net/support/red-lion ... sentations
on y voit que la com ethernet est en SLAVE ! la tienne est en master..
mais dans la vidéo, la conversion va de RS485 -> ethernet
Est-ce ton cas ou bien as-tu l'inverse ?

sinon reste le support technique : techsupport@redlion.net
Si vous faites rien aujourd'hui et que votre chef vous dit que vous faisiez déjà ça hier, répondez qu'hier vous aviez pas fini !

Avatar de l’utilisateur
bipcoyote
Première mise en service
Première mise en service
Messages : 72
Enregistré le : 16 janv. 2018, 13:19
Localisation : Dunkerque

Re: REDLION

Message par bipcoyote » 04 avr. 2018, 09:19

Bonjour,

Regarde du côté GE, la doc ou appel le constructeur, pour moi c'est de se côté le problème.

Perso, si un changement de protocole entre constructeur, tout de suite passerelle REDLION DPLE, ça se configure très rapidement.

Pour répondre à ta question, le REDLION est master car c'est lui qui fait tout, aucune com à paramétrer de chaque côté (ici GE et API, éventuellement créer une liaison), sauf mettre les tables à disposition.

++

MikeKol
Générateur de blocs fonctions
Générateur de blocs fonctions
Messages : 137
Enregistré le : 22 oct. 2015, 20:20

Re: REDLION

Message par MikeKol » 04 avr. 2018, 14:36

Donc oui cela viens bien de GE, un technicien de la cogénération est venu, même lui n'arrive pas à ce connecter. Donc j’attends son retour.

Avatar de l’utilisateur
jpratpsft
Générateur de blocs fonctions
Générateur de blocs fonctions
Messages : 102
Enregistré le : 24 nov. 2015, 11:10
Localisation : Blagnac
Contact :

Re: REDLION

Message par jpratpsft » 04 avr. 2018, 14:37

Salut,

La première étape serait d'avoir une communication bidirectionnelle.
Si la LED Tx clignotte mais pas la LED Rx, il y a un souci au niveau bas (électrique ou d'adresse).

Si c'est électrique, ça peut être une inversion Tx/Rx, cela peut être vérifié simplement en inversant les 2 fils.
Normalement le 1 va sur le 8 et inversement, mais parfois, c'est différent, donc l'inversion de polarité est un bon tests (et facile à tester).

Si c'est un problème d'adresse, c'est plus vicieux, un esclave Modbus ne répond que si son adresse est demandée.
Tu pourrais peut-être envoyer une commande de lecture à l'esclave 255 (broadcast), tous les esclaves sont censés répondre (si supporté).

Personnellement, je ferai l'essai avec un simulateur Modbus esclave (Modbus Doctor, ModSim, The Vinci...) sur un PC via le port RS232 de la passerelle REDLION.
Si cela fonctionne, il faut essayer avec les même port RS232 du REDLION en utilisant un convertisseur RS232/485 pour voir si la communication fonctionne avec ce port, si ça a fonctionné avec le PC ça doit marcher avec le GE.

Le convertisseur RS232/485 peut être utilisé avec un simulateur Modbus maître (ModScan par exemple) pour tester la communication entre le PC et le GE afin de voir si ça fonctionne dans cette configuration.
Si les tests avec les simulateurs fonctionnent, alors il suffit de câbler de la même manière mais sans les convertisseurs ce coup-ci.

En espérant aider...

@+
--
Commissaire Bialès : Parlez-moi de vous plutôt…
Odile Deray : Odile. Moi, c'est Odile. Pluto, c'est l'ami de Mickey.
Commissaire Bialès : Ah non, Pluto c'est le chien de Mickey. L'ami de Mickey c'est Dingo.
La cité de la peur

Répondre