Defaut Profibus DP

Partie du forum pour tout ce qui concerne la partie réseau de communication dans l'industrie. Forum, conseil, astuce et entraide sur le réseau industriel tel que la connexion modbus, ethernet, fipio .
Répondre
neophyte
Code sa première boucle
Code sa première boucle
Messages : 13
Enregistré le : 10 mars 2017, 15:20

Defaut Profibus DP

Message par neophyte » 20 avr. 2018, 07:49

Bonjour,
Sur un réseau profibus DP, j'ai un soucis de stabilité. Parfois ça marche, parfois ça plante.
Le signal est effectivement pourri, mais je n'en comprends pas la raison:
Les terminaisons sont bonnes (résistances échangées), les mises à la masse sont OK, les connexions vérifiées, pas de défaut visible sur les câbles.
Ce réseau était OK il y a environ deux ans (date du dernier passage), il y a eu semble t il une dégradation entre temps, et que le signal se trouve sur la limite aujourd'hui.
Auriez vous une idée de la cause d'une telle perturbations ?
Merci de vos lumieres !
PBus.jpg

(Nb: pour ce test, la station 7 est effectivement deconnectée )

Avatar de l’utilisateur
JC87
Dieu du process
Dieu du process
Messages : 777
Enregistré le : 20 oct. 2015, 13:00
Localisation : Nouvelle Aquitaine

Re: Defaut Profibus DP

Message par JC87 » 20 avr. 2018, 10:24

Bonjour,

C'est quoi comme type de connecteurs sur les stations ?

JC
"On veut faire du zéro défaut mais on a zéro bonhomme et zéro budget, et bien à la fin on a zéro résultat..."

neophyte
Code sa première boucle
Code sa première boucle
Messages : 13
Enregistré le : 10 mars 2017, 15:20

Re: Defaut Profibus DP

Message par neophyte » 20 avr. 2018, 11:34

Bonjour Jc87,
Je ne suis pas sur site, mais de memoire il y 4 var, une passerelle DP/DP et une UC siemens tous avec des connecteurs subD profibus, et puis il y a une station Festo avec des connecteurs M12 (profibus aussi !) . Il y a aussi deux stations HMI mobile Siemens, sur connecteurs integrés aux stations.

Avatar de l’utilisateur
JC87
Dieu du process
Dieu du process
Messages : 777
Enregistré le : 20 oct. 2015, 13:00
Localisation : Nouvelle Aquitaine

Re: Defaut Profibus DP

Message par JC87 » 20 avr. 2018, 11:48

Si il a des connecteur Sub D à vis il faut impérativement les remplacer par des Fastconnect. Pour les connecteurs M12 si il ne sont pas moulés mais vissés également, il faut refaire la connectique en recoupant légèrement les extrémités et revisser. Je ne dis pas que le probléme vient forcément de là mais ce sont des points a vérifier en premier car la connectique a vis a tendance à s’oxyder et occasionne une perte du signal.

JC
"On veut faire du zéro défaut mais on a zéro bonhomme et zéro budget, et bien à la fin on a zéro résultat..."

neophyte
Code sa première boucle
Code sa première boucle
Messages : 13
Enregistré le : 10 mars 2017, 15:20

Re: Defaut Profibus DP

Message par neophyte » 20 avr. 2018, 14:13

Merci pour cette piste !
Mais tous les connecteurs, subD comme M12 sont à clips, tous les connecteurs à vis ont déja été remplacés .... sans amélioration .
Cette forme de signal me semblait plutôt évoquer un bruit de parasitage, mais ou chercher ???

Avatar de l’utilisateur
ProfnovA
Générateur de blocs fonctions
Générateur de blocs fonctions
Messages : 148
Enregistré le : 21 oct. 2015, 08:21

Re: Defaut Profibus DP

Message par ProfnovA » 20 avr. 2018, 14:20

JC87 a écrit :
20 avr. 2018, 11:48
la connectique a vis a tendance à s’oxyder et occasionne une perte du signal.
La présence de CO2 et/ou de H2S accelere également la corrosion des aciers (station d'épuration par ex).

Avatar de l’utilisateur
JC87
Dieu du process
Dieu du process
Messages : 777
Enregistré le : 20 oct. 2015, 13:00
Localisation : Nouvelle Aquitaine

Re: Defaut Profibus DP

Message par JC87 » 20 avr. 2018, 14:54

Quelle est la vitesse qui a été paramétré sur ce réseau Profibus ? si vitesse élevée attention à la longueur du réseau. Pour s'assurer qu'on est dans les clous, l'outil de test BT 200 donne la valeur de longueur telle qu'elle est vue du réseau; des fois on des surprises.

JC
"On veut faire du zéro défaut mais on a zéro bonhomme et zéro budget, et bien à la fin on a zéro résultat..."

neophyte
Code sa première boucle
Code sa première boucle
Messages : 13
Enregistré le : 10 mars 2017, 15:20

Re: Defaut Profibus DP

Message par neophyte » 20 avr. 2018, 17:07

Je vais regarder la vitesse, mais il me semble bien qu'il ne s'agit pas d'un "incident de fonctionnement", encore moins de défaut de paramétrage, mais plutôt d'une dégradation progressive.
Je regarde ces paramètres dès lundi, et vous tiens au courant.
Le BT200 me donne un câblage correct, pas de défaut pour lui.
La cellule tiens dans 10m x 6m, le réseau n'est pas en toile d'araignée non plus ... on est loin des 100mL.

Merci de vos pistes !!!

cedric59
Aguerri de l'automation
Aguerri de l'automation
Messages : 83
Enregistré le : 09 oct. 2017, 13:53

Re: Defaut Profibus DP

Message par cedric59 » 30 mai 2018, 18:01

Bonjour, vous utilisez quelle logiciel pour le test sur le réseaux profibus ?

Avatar de l’utilisateur
jpratpsft
Générateur de blocs fonctions
Générateur de blocs fonctions
Messages : 102
Enregistré le : 24 nov. 2015, 11:10
Localisation : Blagnac
Contact :

Re: Defaut Profibus DP

Message par jpratpsft » 04 juin 2018, 16:00

cedric59 a écrit :
30 mai 2018, 18:01
Bonjour, vous utilisez quelle logiciel pour le test sur le réseaux profibus ?
Chez nous on utilise un hard specifique (ProfiCore) et un soft associé (ProfiTrace) de chez Procentec.
Il y a plusieurs variantes avec différents niveaux de prix, la basique va bien si tu dois faire du diagnostic d'un réseau existant par exemple ou si tu es sûr que le cablage est correct, d'autres versions intègrent un oscilloscopde et plein d'autre fonctions.
--
Commissaire Bialès : Parlez-moi de vous plutôt…
Odile Deray : Odile. Moi, c'est Odile. Pluto, c'est l'ami de Mickey.
Commissaire Bialès : Ah non, Pluto c'est le chien de Mickey. L'ami de Mickey c'est Dingo.
La cité de la peur

Répondre