Défauts de communication ATV340

Partie du forum pour tout ce qui concerne les variateurs de vitesse dans l'industrie. Forum, conseil, astuce et entraide sur les variateurs de fréquence .
Répondre
Avatar de l’utilisateur
JC87
Mi homme - Mi automate
Mi homme - Mi automate
Messages : 1114
Enregistré le : 20 oct. 2015, 13:00
Localisation : Nouvelle Aquitaine

Défauts de communication ATV340

Message par JC87 » 23 juin 2020, 09:04

Bonjour,

Sur une machine équipé de deux variateurs ATV340 en communication Ethernet Modbus TCP avec un M241 j'ai des pertes de communications récurrentes qui me font passer les variateurs en roue libre et me foutent un gros bordel sur la machine. Le diagnostic en ligne montre ces défauts mais sans horodatage et j'ai eu beau chercher sur site dans Somove je ne trouve pas ou régler l'heure sur le variateur. Ça m'intéresserai beaucoup de savoir quand se produise exactement ces défauts pour essayer d'en trouver la cause parce que le réseau est très peu chargé (deux variateurs, un afficheur et un contrôleur de sécurité en com Modbus TCP) et le câblage des variateurs ayant été fait dans les règles de l'art je ne comprend absolument pas d’où viennent ces pertes de communication.
Dépileur Fillmatic -Erreurs Axe X.png
JC
"On veut faire du zéro défaut mais on a zéro bonhomme et zéro budget, et bien à la fin on a zéro résultat..."

Avatar de l’utilisateur
itasoft
Mi homme - Mi automate
Mi homme - Mi automate
Messages : 4009
Enregistré le : 20 oct. 2015, 10:15
Localisation : Lyon
Contact :

Re: Défauts de communication ATV340

Message par itasoft » 23 juin 2020, 09:31

slts,
A la grosse je dirais que c'est pas obligé que ça soit le VAR qui donne l'heure, es que l'automate est à l'heure sur le méridien de Greenwich ?
Le DRIVE c'est une fonction logiciel ou un constituant physique ?
Modifié en dernier par itasoft le 23 juin 2020, 10:11, modifié 1 fois.
Automaticien privé (de tout)
itasoft@free.fr

Titipass
Apprend le binaire
Apprend le binaire
Messages : 10
Enregistré le : 28 nov. 2019, 09:26

Re: Défauts de communication ATV340

Message par Titipass » 23 juin 2020, 09:49

Bonjour,

A priori, on devrait pouvoir, à partir de l'automate, envoyer l'heure sur le drive. Si tu veux avoir l'heure et la garder sur le drive, il faut une console (batterie dans la console pas dans le drive).
A partir du moment ou l'heure est initialisée sur le drive (par la console ou par la liaison série) les horodatages devraient se faire.

Avatar de l’utilisateur
JC87
Mi homme - Mi automate
Mi homme - Mi automate
Messages : 1114
Enregistré le : 20 oct. 2015, 13:00
Localisation : Nouvelle Aquitaine

Re: Défauts de communication ATV340

Message par JC87 » 23 juin 2020, 11:35

J'ai bien une console sur chaque variateurs mais je ne sais pas si il y a une batterie à l'intérieur. Quoiqu'il en soit j'ai beau bourniquer dans les menus et je n'ai pas trouvé ou régler l'heure. Faut que je consulte la doc.

JC
"On veut faire du zéro défaut mais on a zéro bonhomme et zéro budget, et bien à la fin on a zéro résultat..."

philou77
Mi homme - Mi automate
Mi homme - Mi automate
Messages : 1191
Enregistré le : 21 oct. 2015, 10:00
Localisation : Ile de France

Re: Défauts de communication ATV340

Message par philou77 » 23 juin 2020, 11:59

Salut !

Dans la doc ils parlent d'un terminal graphique branché à la mise sous tension du variateur ou d'un serveur web configuré pour l'horodatage !
Si tu as ce terminal de raccordé, tu devrais pouvoir accéder au menu de mise à l'heure

https://download.schneider-electric.com ... f=NVE61644

Page 567.
Si vous avez compris tout ce que je viens d'écrire, c'est que j'ai dû faire une erreur quelque part ! :D

Titipass
Apprend le binaire
Apprend le binaire
Messages : 10
Enregistré le : 28 nov. 2019, 09:26

Re: Défauts de communication ATV340

Message par Titipass » 23 juin 2020, 12:26

La console qui gere la RTC (Real Time Clock), c'est la "grosse" VW3A1111 (pas la "petite" VW3A1113). Le plus simple est d'envoyer l'heure par l'automate.

Avatar de l’utilisateur
Bruce33
Forcené des structures
Forcené des structures
Messages : 183
Enregistré le : 28 oct. 2015, 06:54
Localisation : Pas-de-Calais

Re: Défauts de communication ATV340

Message par Bruce33 » 23 juin 2020, 13:05

Bonjour,

J'ai eu le même besoin et le même problème il y a quelque temps. Un des variateurs ATV340 s'est mis à l'heure je ne sais pas comment (par le serveur web mais je ne suis pas sûr) et avec l'autre je n'ai pas réussi. Mais comme j'ai trouvé la source des "pannes" je n'ai pas creusé le sujet.

Les infos Schneider ne sont pas forcément rassurantes : https://www.se.com/us/en/faqs/FA361241/
Traduction :
Il n'est pas possible de modifier l'horodatage de la série ATV340 via SoMove. Actuellement, il n'est pas possible de mettre à jour l'horodatage de la série ATV340 via le serveur Web. Il s'agit d'un problème connu qui devrait être corrigé dans une mise à jour du micrologiciel au premier trimestre 2019.
Actuellement, pour régler l'horodatage dans un variateur ATV340, activez le serveur SNTP afin de permettre au variateur de récupérer la date et l'heure de l'horloge réseau.
Donc cela dépend de la version du firmware du variateur.
Peut-être aussi que la version du firmware du terminal VW3A1111 permet ou non certains réglages.

Avatar de l’utilisateur
JC87
Mi homme - Mi automate
Mi homme - Mi automate
Messages : 1114
Enregistré le : 20 oct. 2015, 13:00
Localisation : Nouvelle Aquitaine

Re: Défauts de communication ATV340

Message par JC87 » 23 juin 2020, 15:17

Titipass a écrit :
23 juin 2020, 12:26
La console qui gere la RTC (Real Time Clock), c'est la "grosse" VW3A1111 (pas la "petite" VW3A1113). Le plus simple est d'envoyer l'heure par l'automate.
Bon c'est mort car j'en ai une petite :mrgreen:

Sinon je n'ai pas de serveur NTP sur ce réseau donc pas de possibilité de ce coté là non plus. Par l'automate je ne sait pas comment faire et de toutes façons je ne veut pas toucher à Somachine car à chaque fois que je travaille avec cette saloperie je finit la journée a deux doigt de fracasser ce truc à coup de marteau :D

En fait l’horodatage pourrait peut être aider mais rien n'est moins sur. D'après cette FAQ en anglais : https://www.se.com/us/en/faqs/index?pag ... cale=en_US
Ce problème est connu mais ils ne donnent aucune solution sérieuse et la doc sur la partie Ethernet en anglais ne donne pas beaucoup plus de pistes.

J'ai changé tous les câbles Ethernet dans l'armoire ainsi que le Switch. On va attendre de voir ce que cela donne. Si j'ai toujours le même problème il sera temps d'appeler Schneider.

JC
"On veut faire du zéro défaut mais on a zéro bonhomme et zéro budget, et bien à la fin on a zéro résultat..."

Répondre