Problème profibus sur Vector 8200

Partie du forum pour tout ce qui concerne les variateurs de vitesse dans l'industrie. Forum, conseil, astuce et entraide sur les variateurs de fréquence .
Répondre
rlubet
Asservi son premier moteur
Asservi son premier moteur
Messages : 22
Enregistré le : 18 nov. 2016, 15:36

Problème profibus sur Vector 8200

Message par rlubet » 28 juil. 2020, 08:47

Bonjour tout le monde,

Je me permets de vous écrire car je rencontre un problème chez un client avec un variateur Lenze de type vector 8200 communicant en profibus avec une CPU Siemens.

Mon problème est le suivant, il arrive de manière aléatoire, et sur des démarrages, que la carte de communication profibus du variateur ai une adresse différente de celle que je lui ai paramétré via l'affectation d'adresse depuis la console Siemens.
De plus, le numéro d'adresse que je retrouve n'est pas systématiquement le même (j'ai eu du 18, 3, 81 ... )
Ce variateur est situé au milieu d'une chaîne de 3 variateurs aussi de marque Lenze et communicant également en profibus, et qui n'ont pas le problème que je vous décris ci-dessus.

Est ce que l'un d'entre aurait des suggestions de vérification que je puisse faire pour résoudre mon problème?

PS : Je suis en attente d'un retour de Lenze sur une carte de com profibus défaillante que je leur ai retourné.

Merci d'avance pour votre aide,

Avatar de l’utilisateur
Bruce33
Codeur fou
Codeur fou
Messages : 203
Enregistré le : 28 oct. 2015, 06:54
Localisation : Pas-de-Calais

Re: Problème profibus sur Vector 8200

Message par Bruce33 » 28 juil. 2020, 20:36

Bonjour,

L'aspect aléatoire du problème fait effectivement penser à une défaillance matérielle...
Mais il faut tout de même envisager toutes les possibilités.

Je ne comprends pas en quoi consiste votre "affectation d'adresse depuis la console Siemens".
Cela signifie-t-il que vous utilisez le logiciel Lenze "Global Drive Control" sur cette console ?

Avez-vous essayé de régler l'adresse directement sur le variateur via le code C1509 (si le variateur dispose d'un clavier de commande) ?
Sauvegardez-vous les paramètres du variateur en mémoire non volatile (EEPROM) ? On utilise normalement le code C0003 pour la sauvegarde.

Quelles sont les valeurs des paramètres C0002 et C0003 (dédiés au chargement et à l'enregistrement des paramètres) ? Sont-ils semblables à ceux des autres variateurs ?

Que fait l'automate via le Profibus : simplement du pilotage ou aussi du réglage de paramètres ?

rlubet
Asservi son premier moteur
Asservi son premier moteur
Messages : 22
Enregistré le : 18 nov. 2016, 15:36

Re: Problème profibus sur Vector 8200

Message par rlubet » 29 juil. 2020, 08:59

Bonjour Bruce33,

Aujourd'hui pour résoudre mon problème j'ouvre la configuration matérielle sur Step7
Dans la partie Système cible, Profibus, je réalise une attribution d'adresse profibus (je remets l'adresse correcte sur l'équipement en question)

Mon client dispose d'une pocket qui s'allume bien quand je la branche au variateur, mais j'ai eu un peu de difficulté à naviguer dans les menus
Savez vous où je peux trouver une documentation pour la navigation dans ceux-ci ?

Du coup, non je n'ai pas vérifieé le C1509
Je n'ai pas fait de sauvegarde via le C0003 (quelle est la procédure?)
Je n'ai pas consulté C0002 & C0003 (comme je ne sais pas comment naviguer avec la pocket)

Via le profibus, je ne suis pas sûr n'ayant pas les sources du programme et mon client ne dispose que de peu d'informations. Mais il effectue à minima du pilotage.

Merci d'avance pour votre aide

Avatar de l’utilisateur
Bruce33
Codeur fou
Codeur fou
Messages : 203
Enregistré le : 28 oct. 2015, 06:54
Localisation : Pas-de-Calais

Re: Problème profibus sur Vector 8200

Message par Bruce33 » 29 juil. 2020, 10:20

La documentation de ce variateur est disponible à cette adresse :
https://www.lenze.com/fr-fr/produits/an ... 00-vector/

Dans le document "Informations destinées à l’exploitant E82EV 8200 vector 0.25-11kW" il y a une présentation de la pocket, à partir de la page 15.
La page 17 décrit la séquence de touches pour atteindre et modifier un paramètre. Ce n'est pas intuitif ! :?

Le document "System manual E82EV 8200 vector 0.25-90kW" (en anglais, mais pas en français) détaille le fonctionnement et le réglage du variateur.

Je suis allé un peu vite concernant le Profibus car il existe 2 modules.
Lequel avez-vous ?

Le paramètre C1509 dont j'ai parlé correspond au modèle E82ZAFPC001 ou E82ZAFPC010

Mais je pense que vous avez plutôt un module EMF2133IB
Dans ce cas, soit l'adresse est configurée avec les interrupteurs DIP, soit avec le code C0009 (quand tous les interrupteurs DIP sont sur OFF).

rlubet
Asservi son premier moteur
Asservi son premier moteur
Messages : 22
Enregistré le : 18 nov. 2016, 15:36

Re: Problème profibus sur Vector 8200

Message par rlubet » 30 juil. 2020, 09:48

Bonjour Bruce33,

Je dispose d'un module E82ZAFPC001
J'ai réussi a avoir un retour de Lenze
il m'a suggéré de vérifier les paramètres
C1509, C1517 et C1530 (C1517 ne sera pas dispo avec la carte dont je dispose)
et C0168 (historique de défauts cf C0161 0162 0163 0164)

je vais voir cela chez mon client aujourd'hui, je vais également vérifier les C0002 et C0003

et comparer avec les 2 autres variateurs de la ligne, je vous tiens au courant

Répondre