Pertes sur une boucle de courant....

Forum traitant des automates industriels de marque Siemens.
valerypetit
Générateur de blocs fonctions
Générateur de blocs fonctions
Messages : 132
Enregistré le : 24 janv. 2016, 21:47

Pertes sur une boucle de courant....

Message par valerypetit » 16 mai 2018, 20:55

Bonjour,

Sur une installation récente, j'ai pu remarquer une petite déviation entre les valeurs mesurées affichés par un capteur (sonde de pression, débitmètre), et celle reçu et mis à l’échelle dans l'automate.
il semblerai que l'on ai quelques pertes entre le capteur et la carte ana mais je vous avoue ne pas avoir suffisamment de reçu sur ce phénomène....

Pour info :
c'est une boucle de courant donc 4/20mA
2 fils Passif ou 4 fils Actif suivant le capteur.
sur un débitmètre avec une gamme allant jusqu'à 20m3/H j'ai pu observer à 7,6 au lieu de 8m3/H

merci d'avance pour votre aide.

Avatar de l’utilisateur
itasoft
Mi homme - Mi automate
Mi homme - Mi automate
Messages : 2400
Enregistré le : 20 oct. 2015, 10:15
Localisation : Lyon
Contact :

Re: Pertes sur une boucle de courant....

Message par itasoft » 17 mai 2018, 01:55

slts,
On est pas des devins, lol

- indiquer si ça le fait sur tous les capteurs ou que sur un seul
- indiquer le type de carte entrées ana. (voies isolées ou non)
- indiquer le type de cable utilisés , la longueur, et le chemin emprunté (par ou sa passe, si c'est mélangé avec les autres cables de puissance)
Automaticien privé (de tout)
itasoft@free.fr

Ronan
Aguerri de l'automation
Aguerri de l'automation
Messages : 95
Enregistré le : 17 juil. 2017, 07:37
Localisation : Saint-Nazaire
Contact :

Re: Pertes sur une boucle de courant....

Message par Ronan » 17 mai 2018, 07:49

valerypetit a écrit :
16 mai 2018, 20:55
Bonjour,

Sur une installation récente, j'ai pu remarquer une petite déviation entre les valeurs mesurées affichés par un capteur (sonde de pression, débitmètre), et celle reçu et mis à l’échelle dans l'automate.
Tes capteurs ont des afficheurs ? Peux-tu mesurer le courant en sortie de capteur et en entrée de carte pour vérifier qu'il y a une différence ?
En 4..20mA, je suis sceptique sur une "perte".
Peux-tu nous montrer la mise à l'échelle ?

valerypetit
Générateur de blocs fonctions
Générateur de blocs fonctions
Messages : 132
Enregistré le : 24 janv. 2016, 21:47

Re: Pertes sur une boucle de courant....

Message par valerypetit » 17 mai 2018, 10:00

Salut
merci pour vos retours,

- indiquer si ça le fait sur tous les capteurs ou que sur un seul
* Dans l’ensemble sur la plupart des capteurs il doit y avoir une légère variation, mais je n'ai pas de chiffre précis à vous donner....

- indiquer le type de carte entrées ana. (voies isolées ou non)
* On est sur un ET200SP, donc carte AI 8xI 2-,4-wire BA (6ES7 134-6GF00-0AA1) tous les diag sont activés (pas de remonté de défaut)

- indiquer le type de cable utilisés , la longueur, et le chemin emprunté (par ou sa passe, si c'est mélangé avec les autres câbles de puissance)

* Câble blindé partout (Sauf sur une petite partie Atex où sont présents des filtres intrinsèque)
* Je dirai que les longueurs sont toujours inférieur à 50m
* à part sur certains tronçons assez court, les câbles ana sont éloigné de la puissance, (dans l'ensemble je pense que l'installation a été faite dans les règles de l'art)

je vous met la mise à l’échelle en PJ, par contre pour la mesure sur capteur, il faudra attendre que je retourne sur site dans 2 semaine.

l'analogique est nouveau pour moi, je n'en faisais pas trop dans ma boite précédente et l'on ne demandait pas la même précision, je n'ai du coup pas beaucoup de recul sur le fonctionnement et les problématiques que l'on peu rencontrer sur une boucle 4/20mA...
Fichiers joints
MAE.png

Avatar de l’utilisateur
itasoft
Mi homme - Mi automate
Mi homme - Mi automate
Messages : 2400
Enregistré le : 20 oct. 2015, 10:15
Localisation : Lyon
Contact :

Re: Pertes sur une boucle de courant....

Message par itasoft » 17 mai 2018, 10:18

slts,
apparemment les voies ne seraient pas isolées entre elles à confirmer, si c'est le cas ça ne vaut rien à mettre à la poubelle.
A savoir:
un professionnel utilise toujours des voies isolées, surtout quand elles sont utilisées en courant et avec des capteurs de type différents.


cliquer dessus
_voies.JPG
Automaticien privé (de tout)
itasoft@free.fr

GG10
Générateur de blocs fonctions
Générateur de blocs fonctions
Messages : 102
Enregistré le : 15 sept. 2016, 14:35

Re: Pertes sur une boucle de courant....

Message par GG10 » 17 mai 2018, 11:01

Bonjour

tu fais une règle de trois dans l'automate pour adapter la valeur automate avec la valeur sur le capteur !!!

Avatar de l’utilisateur
itasoft
Mi homme - Mi automate
Mi homme - Mi automate
Messages : 2400
Enregistré le : 20 oct. 2015, 10:15
Localisation : Lyon
Contact :

Re: Pertes sur une boucle de courant....

Message par itasoft » 17 mai 2018, 11:18

slts,
tu fais une règle de trois dans l'automate pour adapter la valeur automate avec la valeur sur le capteur !!!

je savais pas que la dérive était une constante, mais si c'est nouveau que ça vient de sortir c'est normal que je sois pas au courant
Automaticien privé (de tout)
itasoft@free.fr

GG10
Générateur de blocs fonctions
Générateur de blocs fonctions
Messages : 102
Enregistré le : 15 sept. 2016, 14:35

Re: Pertes sur une boucle de courant....

Message par GG10 » 17 mai 2018, 11:38

alors tu fais une courbe étalonnage, tu calcules les caractéristiques de ta courbe et tu l'appliques a l'automate !!!

Avatar de l’utilisateur
itasoft
Mi homme - Mi automate
Mi homme - Mi automate
Messages : 2400
Enregistré le : 20 oct. 2015, 10:15
Localisation : Lyon
Contact :

Re: Pertes sur une boucle de courant....

Message par itasoft » 17 mai 2018, 13:43

slts,
OK, c'est bon
Automaticien privé (de tout)
itasoft@free.fr

valerypetit
Générateur de blocs fonctions
Générateur de blocs fonctions
Messages : 132
Enregistré le : 24 janv. 2016, 21:47

Re: Pertes sur une boucle de courant....

Message par valerypetit » 17 mai 2018, 14:51

ça n'est pas moi qui ai commandé le matériel,
mais, tu me dira, j'aurai probablement fais la même erreur.

à quoi cela sert-il de vendre des cartes avec des voies non isolée?
tu pense que mon problème viendrait de là?

Répondre