ATV 320 CONFIGURATION IO SCANNER (M221)

Forum traitant des automates industriels de marque Schneider - Telemecanique
Répondre
KOUKOU
Apprend le binaire
Apprend le binaire
Messages : 10
Enregistré le : 17 avr. 2018, 17:24

ATV 320 CONFIGURATION IO SCANNER (M221)

Message par KOUKOU » 01 août 2018, 12:22

bonjours à tous
j'ai un petit problème j'essai de faire régler mes variateur AT320 par Modbus TCP donc j'ai activé la structure E/S j'ai ajouté les équipements j'ai entré manuellement leur l'adresse IP dans les variateurs mais mon automates n'arrive pas à faire une communication dans les bloc Mc_power_atv0 affiche erreur IO Scanner
mon variateur je le vois sur le serveur quand je fait un ping de son adresse ip

est ce que y'a t'ils des paramètres spécifiques ?

Merci par avance

hcx0125
Apprend le binaire
Apprend le binaire
Messages : 8
Enregistré le : 16 déc. 2015, 20:32

Re: ATV 320 CONFIGURATION IO SCANNER (M221)

Message par hcx0125 » 05 août 2018, 16:55

Bonjour,
Vérifiez si vous avez bien choisi "ATV320_ETH_Direct" dans Modbus TCP IOScanner.
Normalement il suffit juste d'entrer IP de ATV320.

Erreur IO Scanner dans Power signifie que M221 n'arrive pas à communiquer avec ATV320.
Vérifiez donc les valeurs de %IWNSxxx

ChrisLBQ
Asservi son premier moteur
Asservi son premier moteur
Messages : 25
Enregistré le : 13 mars 2016, 16:11

Re: ATV 320 CONFIGURATION IO SCANNER (M221)

Message par ChrisLBQ » 10 août 2018, 18:20

Pas de retour on suppose que c'est tout bon ?

:lol:

Anthony27
Apprend le binaire
Apprend le binaire
Messages : 5
Enregistré le : 25 janv. 2019, 08:25

Re: ATV 320 CONFIGURATION IO SCANNER (M221)

Message par Anthony27 » 25 janv. 2019, 08:40

Bonjour,

J'ai le même type de problème avec des variateurs ATV320. J'ai renseigné les adresses IP manuellement. Depuis Somove, j'arrive à me connecter aux ATV. je les pilotes sans problème.

Depuis mon TM221CE40R, je veux piloter les variateurs.

Pour ce faire, j'ai renseigné les IP de mes deux variateurs dans Modbus TCP en activant le scrutateur d'E/S modbus TCP. J'ai sélectionné ATV320_ETH_DIRECT.

j'utilise le MC_POWER ATV que j’exécute avec un bit.

j'ai l'erreur IOSCANNER
j'ai donc vérifier les variables: %SW212 = 3
%IWNS300 = 3
%IWNS300.0 = -2

Si on reste connecté avec Somove, est ce que la communication peut se faire entre TM221 et ATV320?

Faut-il modifier un paramètre spécifique dans le variateur pour autoriser la com?
Voici les paramètres que j'ai modifié dans Somove:
- FR1 = Carte COM.
- CD1 = Carte COM.

Merci d'avance pour votre aide. Je serais de nouveau face à l'installation lundi

Avatar de l’utilisateur
Relax1485
Première mise en service
Première mise en service
Messages : 58
Enregistré le : 02 oct. 2017, 11:45
Localisation : MONTAUBAN

Re: ATV 320 CONFIGURATION IO SCANNER (M221)

Message par Relax1485 » 25 janv. 2019, 10:52

Si connection SoMove en Ethernet et le M221 aussi en Ethernet alors il se peut en effet qu'il y ait conflit.
Essaye sans le SoMove, sinon bien vérifier dans le 320 que le scan IO est activé.
Ta config du M221 est correcte d'après moi.
Que de temps perdu à gagner du temps... 8-)

Anthony27
Apprend le binaire
Apprend le binaire
Messages : 5
Enregistré le : 25 janv. 2019, 08:25

Re: ATV 320 CONFIGURATION IO SCANNER (M221)

Message par Anthony27 » 25 janv. 2019, 12:40

Merci de ta réponse.
Quel serait le paramètre pour activer l'IOscanner dans l'ATV320?
Dans communication, j'ai ceci:

- Scanner com. entrée
- NMA1 = 3201
- NMA2 = 8604
- Scanner com. sorties
- NCA1 = 8501
- NCA2 = 8602

j'ai la même chose dans Input Output Scanner

- Input Scanner Section
- OMA1 = 3201
- OMA2 = 8604
- Output Scanner Section
- OCA1 = 8501
- OCA2 = 8602

Anthony27
Apprend le binaire
Apprend le binaire
Messages : 5
Enregistré le : 25 janv. 2019, 08:25

Re: ATV 320 CONFIGURATION IO SCANNER (M221)

Message par Anthony27 » 28 janv. 2019, 08:43

Je suis actuellement sur site avec mes variateurs.

J'ai essayé de me connecter depuis le TM221 sans être connecté avec Somove. Même resultat

Avatar de l’utilisateur
Relax1485
Première mise en service
Première mise en service
Messages : 58
Enregistré le : 02 oct. 2017, 11:45
Localisation : MONTAUBAN

Re: ATV 320 CONFIGURATION IO SCANNER (M221)

Message par Relax1485 » 28 janv. 2019, 09:37

Si tu parles ou comprends l'espagnol :
https://www.youtube.com/watch?v=qEY5upndYcc

;)
Que de temps perdu à gagner du temps... 8-)

Anthony27
Apprend le binaire
Apprend le binaire
Messages : 5
Enregistré le : 25 janv. 2019, 08:25

Re: ATV 320 CONFIGURATION IO SCANNER (M221)

Message par Anthony27 » 28 janv. 2019, 09:44

Merci pour la vidéo. Je l'ai déjà vu.

J'ai résolu mon problème. En fait, Je n'avais pa coché la case "activé" du mappage Modbus dan Somachinebasic et je n'avais pas renseigné l'adresse carte com. Dans le le variateur (AMOC) qui doit être identique au mappage modbus du TM221.

Merci encore pour l'aide!

Répondre