La SP9 de Vijeo Designer, pas très nette !

Partie du forum pour tout ce qui concerne les interfaces homme machine ou IHM. Forum, conseil, astuce et entraide sur les interface homme machine ou IHM tels que les magelis, KEP, proface, XBT, .
Répondre
Avatar de l’utilisateur
Béryl
Dieu du process
Dieu du process
Messages : 784
Enregistré le : 20 oct. 2015, 12:00
Localisation : localhost

La SP9 de Vijeo Designer, pas très nette !

Message par Béryl » 10 janv. 2020, 12:01

Amis cyborgs,

Je viens de m'astiquer le neurone sur un de mes projets qui plantait magnifiquement après avoir passé les écrans (HMIGTO) sous la SP9 de Vijeo Designer 6.2.
Déjà, j'aurai dû me méfier, la simulation se comportait bizarrement. Mes menus déroulants, par exemple, étaient complètement décalés alors que j'avais rien touché.
Bon, je les recale et tout rentre dans l'ordre.
Mais une fois envoyé dans les écrans, patatra, tout se retrouve décalé à nouveau !
En remettant les anciennes valeurs, tout rentre dans l'ordre à nouveau... sauf dans la simulation où tout est en vrac :evil:
Bon, l'important, c'est les IHM opérateurs, donc je laisse comme ça.

Sauf que... "Allo Béryl, ça marche plus !!!"
J'y vais voir et effectivement, c'est le dawa dans un de mes scripts ! Gros plantage (script interrompu car trop long) et retour à la page d'accueil avec des couleurs hyper flashies :shock:
Redémarrage du runtime : idem...

Bon, je vous le fais court : ils ont changé un truc au niveau horloge et mes boucles d'attente sont trop longues.
Obligé de tout diviser par 200 pour que ça rentre dans les clous.

Bref, un gros bordel suite à une simple mise à jour (le projet que j'ai renvoyé dans les IHM avait des modifs minimes).
Je vais tâcher de faire remonter l'info chez Schneider.

Avatar de l’utilisateur
itasoft
Mi homme - Mi automate
Mi homme - Mi automate
Messages : 3636
Enregistré le : 20 oct. 2015, 10:15
Localisation : Lyon
Contact :

Re: La SP9 de Vijeo Designer, pas très nette !

Message par itasoft » 10 janv. 2020, 12:08

slts,
le SP8 sur Unitelway seulement c'est buggé à mort, une catastrophe
le SP9 c'est bourré de buggs, un désastre
il faut s’arrêter a la SP7 en attendant des jours meilleurs
Automaticien privé (de tout)
itasoft@free.fr

Avatar de l’utilisateur
Bruce33
Générateur de blocs fonctions
Générateur de blocs fonctions
Messages : 136
Enregistré le : 28 oct. 2015, 06:54
Localisation : Pas-de-Calais

Re: La SP9 de Vijeo Designer, pas très nette !

Message par Bruce33 » 13 janv. 2020, 10:06

Bonjour,

Merci Béryl pour cette mise en garde.
Toutes mes condoléances pour avoir souffert de ces vices de fonctionnement...

J'ai réchappé de justesse à l'installation du SP9 du fait qu'il refuse de s'installer à côté de SoMachine 4.x ou de Machine Expert 1.1. C'est un moindre mal visiblement.

Je m'aperçois aujourd'hui qu'il existe un hotfix qui semble résoudre une partie des problèmes rencontrés :
https://www.se.com/ww/en/faqs/FA385715/
C'est sur le site Schneider Electric en langue anglaise mais pas encore française... (Pourquoi donc ?)

J'aimerais savoir pourquoi la mise à jour est incompatible avec SoMachine/Machine Expert... Encore une contrainte logicielle supplémentaire à contre-courant de l'image commerciale d'une plateforme EcoStruxure harmonieuse !

Cela fait 2 versions successives délivrées avec des dysfonctionnements inacceptables.
Est-ce que Schneider Electric aurait embauché un saboteur envoyé par un concurrent ?
Ou est-ce une tentative de tuer Vijeo Designer pour faire la place à EcoStruxure Operator Terminal Expert (ex-Vijeo XD) ? (Vijeo Designer fait partie des logiciels qui n'ont pas été renommés.)

Avatar de l’utilisateur
Béryl
Dieu du process
Dieu du process
Messages : 784
Enregistré le : 20 oct. 2015, 12:00
Localisation : localhost

Re: La SP9 de Vijeo Designer, pas très nette !

Message par Béryl » 13 janv. 2020, 11:00

Ah merci Bruce, il semble effectivement qu'un patch soit prévu (je vais quand même attendre qu'il sorte sur Xls).
C'est vrai que ça commence à faire beaucoup comme boulettes...
Il va finir par être renommé Drouille Designer, dans le coin, si ça continue :D

dpo
Générateur de blocs fonctions
Générateur de blocs fonctions
Messages : 120
Enregistré le : 27 nov. 2015, 20:03

Re: La SP9 de Vijeo Designer, pas très nette !

Message par dpo » 13 janv. 2020, 23:46

et ils le vendent !!
je pense faire de même sur mes projets :
je livre plein de bugs
je propose un abonnement pour corriger les bugs
tous les 6 mois j'envoie un correctif qui génère de nouveaux bugs
c'est bon ça !

Avatar de l’utilisateur
Béryl
Dieu du process
Dieu du process
Messages : 784
Enregistré le : 20 oct. 2015, 12:00
Localisation : localhost

Re: La SP9 de Vijeo Designer, pas très nette !

Message par Béryl » 14 janv. 2020, 07:48

dpo a écrit :
13 janv. 2020, 23:46
et ils le vendent !!
je pense faire de même sur mes projets :
je livre plein de bugs
je propose un abonnement pour corriger les bugs
tous les 6 mois j'envoie un correctif qui génère de nouveaux bugs
c'est bon ça !
Tu bosses pour Microsoft ?... ;)

Avatar de l’utilisateur
JC87
Mi homme - Mi automate
Mi homme - Mi automate
Messages : 1033
Enregistré le : 20 oct. 2015, 13:00
Localisation : Nouvelle Aquitaine

Re: La SP9 de Vijeo Designer, pas très nette !

Message par JC87 » 14 janv. 2020, 08:10

Béryl a écrit :
14 janv. 2020, 07:48
dpo a écrit :
13 janv. 2020, 23:46
et ils le vendent !!
je pense faire de même sur mes projets :
je livre plein de bugs
je propose un abonnement pour corriger les bugs
tous les 6 mois j'envoie un correctif qui génère de nouveaux bugs
c'est bon ça !
Tu bosses pour Microsoft ?... ;)
Excellent :mrgreen:

JC
"On veut faire du zéro défaut mais on a zéro bonhomme et zéro budget, et bien à la fin on a zéro résultat..."

Répondre