Caméra cognex NON ACCESSIBLE sous TIA Portal.

Forum traitant des automates industriels de marque Siemens.
Répondre
Avatar de l’utilisateur
maxpeigne
Créateur de langage
Créateur de langage
Messages : 616
Enregistré le : 11 oct. 2015, 17:31
Localisation : Nord pas de calais

Caméra cognex NON ACCESSIBLE sous TIA Portal.

Message par maxpeigne » 13 févr. 2020, 08:13

Bonjour à tous,

Je suis sur un projet avec des cameras Cognex Dataman260 connectées sur une CPU1517F-3 en profinet.

Mon souci est qu'une fois que j'ai affecté le noms de certaines caméras via TIA, je les voient toujours NON ACCESSIBLE dans la vue du reseau.
Quelque chose de bizarre, c'est que cela ne le fait que sur certaines cameras. En fait j'arrive à faire fonctionner 4 caméras (que l'on nommera les cameras Z2-Z3), mais j'ai le problème sur les deux dernières (les cameras Z8).

Je ne pense pas que c'est un problème de camera car lorsque j'injecte le GSD d'une camera qui fonctionne (par ex. une Z3) dans une camera qui ne va pas (une Z8), alors je la vois bien sur le réseau s'afficher comme une camera Z3. Dans le doute j'ai quand même remplacer les caméra par des neuves, le problème reste entier...
J'imagine que mon problème se situe donc au niveau de mon GSD ou de ma configuration automate. J'ai vérifié a plusieurs reprises les GSD entre les Z3 et les Z8, ceux ci sont paramétrés à l'identique.

Pour l'exemple ma configuration est celle ci:
config_data.png
config_data.png (11.3 Kio) Vu 1690 fois
Dans les partenaires accessibles, je la vois bien paramétrée:
abonn_accessible.png
abonn_accessible.png (1.99 Kio) Vu 1690 fois
Et pour autant je la vois non accessible.

J'ai vérifié que j'avais bien les derniers GSD, j'ai supprimé recréé plusieurs fois les GSD,mais rien n'y fait.

Avez vous une idée de ce qui peut poser problème?

Merci.
http://automacile.fr - Site et tutoriels sur l'arduino.

Avatar de l’utilisateur
Daviddu90
Générateur de blocs fonctions
Générateur de blocs fonctions
Messages : 104
Enregistré le : 18 janv. 2019, 08:23
Localisation : Territoire de Belfort
Contact :

Re: Caméra cognex NON ACCESSIBLE sous TIA Portal.

Message par Daviddu90 » 13 févr. 2020, 08:17

Hi,

Tu as rechargé ta configuration matériel?
Tu peux envoyer une vue de ta configuration matériel avec les ip affiché stp.

David
Automaticien Indépendant
https://www.dpiautom.com/

Avatar de l’utilisateur
maxpeigne
Créateur de langage
Créateur de langage
Messages : 616
Enregistré le : 11 oct. 2015, 17:31
Localisation : Nord pas de calais

Re: Caméra cognex NON ACCESSIBLE sous TIA Portal.

Message par maxpeigne » 13 févr. 2020, 10:22

Salut David,

Oui j'ai rechargé complétement l'automate, et j'ai meme fais une compilation matérielle avant de recharger.

Voici la config matérielle d'un Dataman defectueux:
config_materielle_01.png
config_materielle_02.png
config_materielle_03.png
Merci.
http://automacile.fr - Site et tutoriels sur l'arduino.

Avatar de l’utilisateur
Daviddu90
Générateur de blocs fonctions
Générateur de blocs fonctions
Messages : 104
Enregistré le : 18 janv. 2019, 08:23
Localisation : Territoire de Belfort
Contact :

Re: Caméra cognex NON ACCESSIBLE sous TIA Portal.

Message par Daviddu90 » 13 févr. 2020, 13:59

Ok, envoi moi aussi ton architecture réseau avec les ip en affichage.
Tu vois tes caméras dans ton réseau insight?

David
Automaticien Indépendant
https://www.dpiautom.com/

Avatar de l’utilisateur
maxpeigne
Créateur de langage
Créateur de langage
Messages : 616
Enregistré le : 11 oct. 2015, 17:31
Localisation : Nord pas de calais

Re: Caméra cognex NON ACCESSIBLE sous TIA Portal.

Message par maxpeigne » 14 févr. 2020, 08:07

Merci pour ton suivi David.

Malheureusement mon client est assez a cheval sur la confidentialité, je ne peux donc pas te mettre l'architecture reseau complete...
Par contre voici le lecteur et l'automate:
reseau02.png
reseau02.png (5.95 Kio) Vu 1640 fois
reseau01.png
Qu'est ce que tu aurais aimé voir sur l'architecture réseau?

Qu'entends tu par réseau insight?
http://automacile.fr - Site et tutoriels sur l'arduino.

Avatar de l’utilisateur
Daviddu90
Générateur de blocs fonctions
Générateur de blocs fonctions
Messages : 104
Enregistré le : 18 janv. 2019, 08:23
Localisation : Territoire de Belfort
Contact :

Re: Caméra cognex NON ACCESSIBLE sous TIA Portal.

Message par Daviddu90 » 14 févr. 2020, 13:52

Hi, juste ton adressage.
Le logiciel Cognex insight explorer. Tu les vois dans ton réseau?

David
Automaticien Indépendant
https://www.dpiautom.com/

Avatar de l’utilisateur
maxpeigne
Créateur de langage
Créateur de langage
Messages : 616
Enregistré le : 11 oct. 2015, 17:31
Localisation : Nord pas de calais

Re: Caméra cognex NON ACCESSIBLE sous TIA Portal.

Message par maxpeigne » 14 févr. 2020, 14:02

Oui je la vois dans cognex insight:
cognex01.png
cognex01.png (5.75 Kio) Vu 1625 fois
cognex03.png
Alors phénomène bizarre. Ce matin mon collègue a passé l'automate en RUN / STOP / RUN sans ne rien faire d'autre (aucune modif), et toutes les caméras sont apparues...
Il n'a rien fait d'autre.

A savoir que durant nos essais précédents, nous avons fais des chargements complet de programme, et il y a même eut des coupures completes de l'armoire. J'ai du mal a comprendre ce qui fait que cela fonctionne maintenant...

Donc le problème n'apparait plus, mais si cela vient a se reproduire, je ne sais pas comment régler le problème...

Si tu as quelques pistes, je suis preneur...

Merci!
http://automacile.fr - Site et tutoriels sur l'arduino.

Avatar de l’utilisateur
Daviddu90
Générateur de blocs fonctions
Générateur de blocs fonctions
Messages : 104
Enregistré le : 18 janv. 2019, 08:23
Localisation : Territoire de Belfort
Contact :

Re: Caméra cognex NON ACCESSIBLE sous TIA Portal.

Message par Daviddu90 » 16 févr. 2020, 14:23

Hi,

Quand sa se passe comme c'est bien mais sa va surement revenir. Peut être que les caméras avait paumer les paramètres et que le redémarrage les à réinitialiser. Allez à plus.

David
Automaticien Indépendant
https://www.dpiautom.com/

Avatar de l’utilisateur
maxpeigne
Créateur de langage
Créateur de langage
Messages : 616
Enregistré le : 11 oct. 2015, 17:31
Localisation : Nord pas de calais

Re: Caméra cognex NON ACCESSIBLE sous TIA Portal.

Message par maxpeigne » 17 févr. 2020, 07:53

Daviddu90 a écrit :
16 févr. 2020, 14:23
Quand sa se passe comme c'est bien mais sa va surement revenir.
C'est clair!

On a un specialiste qui vient dans quelques semaines. J'espere qu'il aura une explication...
Si j'ai des nouvelles je vous tiendrai au courant.

Merci pour ton aide ;)
http://automacile.fr - Site et tutoriels sur l'arduino.

Répondre