Communication Profinet entre module ARO et Yaskawa

Forum robot motoman
Répondre
Bastien
Code son premier grafcet
Code son premier grafcet
Messages : 50
Enregistré le : 23 oct. 2020, 10:47
Localisation : VICHY

Communication Profinet entre module ARO et Yaskawa

Message par Bastien »

Bonjour à tous,

Je dois établir la communication entre un contrôleur Micro 2x16 III et un contrôleur Yaskawa YRC1000.
Le Micro parle en DeviceNet et passe par une passerelle DeviceNet/Profinet (Anybus X-gateway AB7647).

Côté Yaskawa, j'ai une carte SST PN-2-PE.
J'ai suivi le fichier "ProfiNet configuration Using MOLEX card SST.... Installations instructions".

J'utilise donc Yaskawa comme maître de la communication et la partie ARO en esclave.

Après avoir configurer la passerelle côté ARO et la carte de communication côté YASKAWA, toutes les LED sont "ok".
Tout m'indique que cela fonctionne cependant je n'ai pas l'impression ça communique.
J'essaye d'activer des bits côté Yaskawa mais pas de visualisation possible côté ARO...
ARO me met des bit a 1 mais cela me semble étrange.

Est ce que quelqu'un à déjà mis en place ce genre d'installation ?

Existe t'il des soft pour tester la communication d'un esclave et d'un maître Profinet séparément afin que je sache de quel côté j'ai un défaut ?

Merci d'avance...
DurandO
Maître du binaire
Maître du binaire
Messages : 412
Enregistré le : 21 mars 2021, 15:31

Re: Communication Profinet entre module ARO et Yaskawa

Message par DurandO »

Bonjour,
coté Yaskawa,tu dois bien avoir un outil de diagnostique.
Sinon, tu peux utiliser Proneta : https://www.plcshare.com/2021/07/downlo ... drive.html avec cela tu pourras diagnostiquer ton réseau profinet et surtout adresser IP et nom objet profinet (8 caractères minuscules).
Bastien
Code son premier grafcet
Code son premier grafcet
Messages : 50
Enregistré le : 23 oct. 2020, 10:47
Localisation : VICHY

Re: Communication Profinet entre module ARO et Yaskawa

Message par Bastien »

Bonjour,
En effet, j'ai réussi à voir l'état des E/S côté Yaskawa à l'aide du soft "Product Configuration Tool".
J'ai également la visualisation de ce que m'envois le module ARO.
Je n'avais pas configuré le bon fichier GSDML ni ouvert une plage suffisante dans le convertisseur.
Tout est réglé et fonctionne !
Répondre